Hasbro Unveils 6″ STAR WARS Black Label Collectors Action Figures

a4301000_6in_luke_package_final-copy-3_4_r536_c534

Today Hasbro announced the creation of it’s new 6″ line of Star Wars figures that will be a “jumping point” for collectors to move from the 3 3/4″ line to Sideshow’s 1/6″ scale figures. Each new figure will cost $19.99 with the current plan of 8 figures being released this year. The first 4 will be available in August and will be Luke Skywalker X-Wing Pilot, R2-D2, Darth Maul, and an Imperial Sandtrooper. They have not announced who the other four characters will be for this year.  The original article states that they’re to be based on the “Original trilogy” but that can’t be the case if Darth Maul is in fact in the mix. I think they must be viewing this line as belonging to the original saga vs. the new Disney films.

Also stated in the announcement is that the popular Vintage line of 3 3/4″ figures will be produced under the “black label” as well. It sounds as though that line will remain more adult-collector centric and the standard 3 3/4″ line might get redone to be less articulated and more kid friendly…we’ll keep you updated as more info comes our way.

Anyways – initial photos of our 6″ Luke Skywalker are stunning! These figures have got to be considered the replacement for the Unleashed line that so many collectors miss a great deal. Read more about these exciting figures HERE!

a4301000_6in_luke_helmet_blaster-4_3_r541_c540

Advertisements

About erikab1123

Hello, I've always loved everything relating to photography. I got my first real 35MM camera when I was in Jr High and have never looked back. I love all things relating to photography - photography and playing with Photoshop!
This entry was posted in SW News and tagged , , , , , , , . Bookmark the permalink.

One Response to Hasbro Unveils 6″ STAR WARS Black Label Collectors Action Figures

  1. Wendy says:

    Hello just wanted to give you a brief heads up and let you
    know a few of the images aren’t loading properly. I’m not sure why but I think its a
    linking issue. I’ve tried it in two different browsers and both show the same outcome.

Comments are closed.